Vulnerabilities / Document Gallery / WPSEC-2026-1957
Document Gallery <= 5.1.1 - Unauthenticated Sensitive Information Exposure of Non-Public Attachments
Medium 5.3
CWE-200Fixed in 5.1.2
- ID
- WPSEC-2026-1957
- Plugin
- Document Gallery (document-gallery)
- Affected
- all versions before 5.1.2
- Remediation
- Update to 5.1.2 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- Weakness
- CWE-200
- Usage
- Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-10-29
- Attack surface
- Document Gallery on WPSec AttackSurface
- Fix released
- Published
Description
The Document Gallery plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 5.1.1, due to the dg_generate_icons and dg_generate_gallery AJAX actions, which are available to logged-out visitors, returning thumbnails and gallery listings for attachments without checking that the requester may read them. This makes it possible for unauthenticated attackers to obtain the titles, links and thumbnails of attachments belonging to private or draft content.
References
- https://wpsec.com/vuln/WPSEC-2026-1957/
- https://plugins.svn.wordpress.org/document-gallery/tags/5.1.2/
- https://wordpress.org/plugins/document-gallery/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS