Vulnerabilities / Document Gallery / WPSEC-2026-1958
Document Gallery <= 5.1.1 - Reflected Cross-Site Scripting via 'mime_types' Parameter
Medium 6.1
CWE-79Fixed in 5.1.2
- ID
- WPSEC-2026-1958
- Plugin
- Document Gallery (document-gallery)
- Affected
- all versions before 5.1.2
- Remediation
- Update to 5.1.2 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weakness
- CWE-79
- Usage
- Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-10-29
- Attack surface
- Document Gallery on WPSec AttackSurface
- Fix released
- Published
Description
The Document Gallery plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'mime_types' value of the dg_generate_gallery AJAX action in all versions up to, and including, 5.1.1, due to the value not being sanitized and the gallery data being printed into a single-quoted HTML attribute without escaping in an HTML response. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
References
- https://wpsec.com/vuln/WPSEC-2026-1958/
- https://plugins.svn.wordpress.org/document-gallery/tags/5.1.2/
- https://wordpress.org/plugins/document-gallery/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS