Vulnerabilities / Premium Packages / WPSEC-2026-1960

Premium Packages <= 7.3.0 - Unauthenticated Insecure Direct Object Reference to Guest Order Status Disclosure

Medium 5.3 CWE-639Fixed in 7.3.1
ID
WPSEC-2026-1960
Plugin
Premium Packages – Sell Digital Products Securely (wpdm-premium-packages)
Affected
from 7.0.0 before 7.3.1
Remediation
Update to 7.3.1 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Weakness
CWE-639
Usage
Plugin Low · Affected versions Low among sites WPSec scans, 2026-10-29
Attack surface
Premium Packages on WPSec AttackSurface
Fix released
Published

Description

The Premium Packages plugin for WordPress is vulnerable to Insecure Direct Object Reference via the checkout order status REST route in all versions up to, and including, 7.3.0, due to the route being public and its ownership check treating a guest order (user ID 0) as owned by any logged-out visitor (current user ID 0). This makes it possible for unauthenticated attackers to read the status, payment status and total of any guest order whose order ID they know or guess.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0