Vulnerabilities / WP Data Access – App Builder for Tables, Forms, Dashboards, Charts & Maps / WPSEC-2026-1965
WP Data Access – App Builder for Tables, Forms, Dashboards, Charts & Maps <= 5.5.89 - Unauthenticated Stored Cross-Site Scripting via Autocomplete Lookup Value
Medium 5.4
CWE-79Fixed in 5.5.90
- ID
- WPSEC-2026-1965
- Plugin
- WP Data Access – App Builder for Tables, Forms, Dashboards, Charts & Maps (wp-data-access)
- Affected
- all versions before 5.5.90
- Remediation
- Update to 5.5.90 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:N
- Weakness
- CWE-79
- Usage
- Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-10-29
- Attack surface
- WP Data Access – App Builder for Tables, Forms, Dashboards, Charts & Maps on WPSec AttackSurface
- Fix released
- Published
Description
The WP Data Access plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the autocomplete lookup field of data entry forms in all versions up to, and including, 5.5.89. The cause is insufficient output escaping: the lookup value read from the lookup table was echoed without escaping into a single-quoted HTML attribute. This makes it possible for unauthenticated attackers who can write data into a lookup table (for example through a public data entry form) to inject arbitrary web scripts that execute when a user opens a data entry form that uses the lookup.
References
- https://wpsec.com/vuln/WPSEC-2026-1965/
- https://plugins.svn.wordpress.org/wp-data-access/tags/5.5.90/
- https://wordpress.org/plugins/wp-data-access/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS