MapPress Maps for WordPress <= 2.97.14 - Unauthenticated Sensitive Information Exposure via Map Embed URL
- ID
- WPSEC-2026-1984
- Plugin
- MapPress – Google Maps, OpenStreetMap & Leaflet (mappress-google-maps-for-wordpress)
- Affected
- all versions before 2.97.15
- Remediation
- Update to 2.97.15 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- Weakness
- CWE-200
- Usage
- Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-10-29
- Attack surface
- MapPress Maps for WordPress on WPSec AttackSurface
- Fix released
- Published
Description
The MapPress plugin for WordPress is vulnerable to Sensitive Information Exposure via the map embed URL (the 'mappress' iframe endpoint) in all versions up to, and including, 2.97.14. This is due to the endpoint applying request-supplied map arguments, including 'otype', 'oid' and 'pois', to an existing map without restriction, and to user-type maps adding each user's account email address to the POI data printed in the page. This makes it possible for unauthenticated attackers to extract the email address of any registered user by loading an existing map with the object type set to 'user' and the object ID set to the target user.
References
- https://wpsec.com/vuln/WPSEC-2026-1984/
- https://plugins.svn.wordpress.org/mappress-google-maps-for-wordpress/tags/2.97.15/
- https://wordpress.org/plugins/mappress-google-maps-for-wordpress/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS