Page and Post Restriction <= 1.6.1 - Authenticated (Subscriber+) Missing Authorization to Plugin Deactivation
- ID
- WPSEC-2026-1990
- Plugin
- Page and Post Restriction (page-and-post-restriction)
- Affected
- all versions before 1.6.2
- Remediation
- Update to 1.6.2 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
- Weakness
- CWE-862
- Usage
- Plugin Low · Affected versions None seen among sites WPSec scans, 2026-10-29
- Attack surface
- Page and Post Restriction on WPSec AttackSurface
- Fix released
- Published
Description
The Page and Post Restriction plugin for WordPress is vulnerable to unauthorized plugin deactivation in all versions up to, and including, 1.6.1 due to a missing capability check on the 'papr_feedback' and 'papr_skip_feedback' deactivation handlers, which relied only on a nonce. That nonce was exposed to any logged-in user because the feedback form's screen check used PHP_SELF, which can be spoofed with a PATH_INFO suffix such as /wp-admin/profile.php/plugins.php. This makes it possible for authenticated attackers, with Subscriber-level access and above, to deactivate the plugin, which removes all content restrictions and, through the deactivation routine, deletes the configured restriction rules.
References
- https://wpsec.com/vuln/WPSEC-2026-1990/
- https://plugins.svn.wordpress.org/page-and-post-restriction/tags/1.6.2/
- https://wordpress.org/plugins/page-and-post-restriction/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS