Vulnerabilities / Import Meetup Events / WPSEC-2026-1996
Import Meetup Events <= 1.7.5 - Authenticated (Subscriber+) Missing Authorization to Meetup Account Deauthorization
Medium 4.3
CWE-862Fixed in 1.7.6
- ID
- WPSEC-2026-1996
- Plugin
- Import Meetup Events – Meetup Sync & Event Aggregator for WordPress (import-meetup-events)
- Affected
- all versions before 1.7.6
- Remediation
- Update to 1.7.6 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
- Weakness
- CWE-862
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-10-30
- Attack surface
- Import Meetup Events on WPSec AttackSurface
- Fix released
- Published
Description
The Import Meetup Events plugin for WordPress is vulnerable to unauthorized modification of data via the ime_deauthorize_action admin-post action in all versions up to, and including, 1.7.5, due to a missing capability check and missing nonce validation on the ime_deauthorize_user function. This makes it possible for authenticated attackers, with Subscriber-level access and above, to delete the stored Meetup authorized user and access token options, which disconnects the site from its Meetup account and stops further imports.
References
- https://wpsec.com/vuln/WPSEC-2026-1996/
- https://plugins.svn.wordpress.org/import-meetup-events/tags/1.7.6/
- https://wordpress.org/plugins/import-meetup-events/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS