Vulnerabilities / SEOPress / WPSEC-2026-2010

SEOPress <= 10.3 - Authenticated (Contributor+) PHP Object Injection via Content Analysis Data

High 7.5 CWE-502Fixed in 10.4
ID
WPSEC-2026-2010
Plugin
SEOPress – AI SEO Plugin & On-site SEO (wp-seopress)
Affected
all versions before 10.4
Remediation
Update to 10.4 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-502
Usage
Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-10-30
Attack surface
SEOPress on WPSec AttackSurface
Fix released
Published

Description

The SEOPress plugin for WordPress is vulnerable to PHP Object Injection in all versions up to, and including, 10.3 due to deserialization of untrusted input when reading stored content analysis rows, where every column, including author-controlled text such as the post title, was passed through maybe_unserialize. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject a PHP object. No known POP chain is present in the vulnerable software itself; if a POP chain is present via an additional plugin or theme installed on the target system, it may allow the attacker to delete arbitrary files, retrieve sensitive data, or execute code.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0