WP Tabs – Responsive Tabs Plugin for WordPress <= 3.1.7 - Authenticated (Contributor+) Stored Cross-Site Scripting via Tab Group Meta
- ID
- WPSEC-2026-2038
- Plugin
- Custom Product Tabs for WooCommerce & WordPress Tabs Builder – Smart Tabs (wp-expand-tabs-free)
- Affected
- all versions before 3.1.8
- Remediation
- Update to 3.1.8 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
- Weakness
- CWE-79
- Usage
- Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-10-30
- Attack surface
- WP Tabs – Responsive Tabs Plugin for WordPress on WPSec AttackSurface
- Fix released
- Published
Description
The Smart Tabs plugin for WordPress is vulnerable to Stored Cross-Site Scripting via tab group metadata in all versions up to, and including, 3.1.7. This is due to the plugin's tab group post types using the default post capabilities instead of the plugin's administrator capability, so lower-privileged users can create tab groups and set their metadata directly. The [wptabs] shortcode then prints the tab content and style values from that metadata without escaping, and it renders unpublished tab groups too. This makes it possible for authenticated attackers with contributor-level access and above to inject arbitrary web scripts in pages that execute whenever a user accesses an injected page.
References
- https://wpsec.com/vuln/WPSEC-2026-2038/
- https://plugins.svn.wordpress.org/wp-expand-tabs-free/tags/3.1.8/
- https://wordpress.org/plugins/wp-expand-tabs-free/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS