Vulnerabilities / Easy SVG Support / WPSEC-2026-2048
Easy SVG Support <= 4.1 - Authenticated (Author+) Stored Cross-Site Scripting via SVG File Upload
Medium 4.4
CWE-79Fixed in 4.2
- ID
- WPSEC-2026-2048
- Plugin
- Easy SVG Support (easy-svg)
- Affected
- all versions before 4.2
- Remediation
- Update to 4.2 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:L/I:L/A:N
- Weakness
- CWE-79
- Usage
- Plugin Low · Affected versions None seen among sites WPSec scans, 2026-10-30
- Attack surface
- Easy SVG Support on WPSec AttackSurface
- Fix released
- Published
Description
The Easy SVG Support plugin for WordPress is vulnerable to Stored Cross-Site Scripting via SVG file uploads in all versions up to, and including, 4.1, due to the bundled enshrined/svg-sanitize 0.22.0 library allowing SMIL animation elements to change a link's href after sanitization. This makes it possible for authenticated attackers with author-level access and above to upload an SVG whose link becomes a javascript: URL in some browsers, executing when a user opens the uploaded file and clicks it.
References
- https://wpsec.com/vuln/WPSEC-2026-2048/
- https://plugins.svn.wordpress.org/easy-svg/tags/4.2/
- https://wordpress.org/plugins/easy-svg/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS