Vulnerabilities / Booktics – Appointment Booking Calendar for Service Businesses / WPSEC-2026-2051
Booktics – Appointment Booking Calendar for Service Businesses <= 1.0.31 - Authenticated (Subscriber+) Sensitive Information Exposure via Calendar Appointments Feed
Medium 5.4
CWE-862Fixed in 1.0.32
- ID
- WPSEC-2026-2051
- Plugin
- Booktics – Appointment Booking Calendar for Service Businesses (booktics)
- Affected
- from 1.0.31 before 1.0.32
- Remediation
- Update to 1.0.32 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
- Weakness
- CWE-862
- Usage
- Plugin Low · Affected versions None seen among sites WPSec scans, 2026-10-30
- Attack surface
- Booktics – Appointment Booking Calendar for Service Businesses on WPSec AttackSurface
- Fix released
- Published
Description
The Booktics plugin for WordPress is vulnerable to Sensitive Information Exposure via the calendar appointments REST feed in version 1.0.31, which reverted the fix from 1.0.28. The feed was available to any logged-in user and was not limited to the caller's own bookings, and it returned each appointment's security token, which is used in cancel and reschedule links. This makes it possible for authenticated attackers, with subscriber-level access and above, to read every customer's booking data and use the leaked tokens to cancel or reschedule other customers' appointments.
References
- https://wpsec.com/vuln/WPSEC-2026-2051/
- https://plugins.svn.wordpress.org/booktics/tags/1.0.32/
- https://wordpress.org/plugins/booktics/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS