Vulnerabilities / Booktics – Appointment Booking Calendar for Service Businesses / WPSEC-2026-2053
Booktics – Appointment Booking Calendar for Service Businesses <= 1.0.31 - Unauthenticated Payment Bypass via Currency Manipulation
Medium 5.3
CWE-472Fixed in 1.0.32
- ID
- WPSEC-2026-2053
- Plugin
- Booktics – Appointment Booking Calendar for Service Businesses (booktics)
- Affected
- from 1.0.31 before 1.0.32
- Remediation
- Update to 1.0.32 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
- Weakness
- CWE-472
- Usage
- Plugin Low · Affected versions None seen among sites WPSec scans, 2026-10-30
- Attack surface
- Booktics – Appointment Booking Calendar for Service Businesses on WPSec AttackSurface
- Fix released
- Published
Description
The Booktics plugin for WordPress is vulnerable to payment manipulation in version 1.0.31, which reverted the fix from 1.0.29. Order creation trusted a buyer-supplied currency even though the total is priced in the store currency, and the Stripe integration accepted any succeeded PaymentIntent as payment without checking its currency, amount or order. This makes it possible for unauthenticated attackers to pay for bookings in a lower-value currency and have them confirmed as paid, on sites that use Stripe payments.
References
- https://wpsec.com/vuln/WPSEC-2026-2053/
- https://plugins.svn.wordpress.org/booktics/tags/1.0.32/
- https://wordpress.org/plugins/booktics/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS