wpDiscuz <= 7.6.73 - Unauthenticated Stored Cross-Site Scripting via Comment Author Name
- ID
- WPSEC-2026-2055
- Plugin
- Comments – wpDiscuz (wpdiscuz)
- Affected
- all versions before 7.6.74
- Remediation
- Update to 7.6.74 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N
- Weakness
- CWE-79
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-10-30
- Attack surface
- wpDiscuz on WPSec AttackSurface
- Fix released
- Published
Description
The wpDiscuz plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the comment author name in all versions up to, and including, 7.6.73. This is due to the comment walker filling comment templates with sequential str_replace() calls. A template placeholder such as {TEXT} in a commenter's name, which is printed in places like the avatar alt attribute, is expanded again into the comment's HTML, which breaks the attribute context. The reply-to author name is also output without escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user, including a moderator viewing a pending comment, accesses an affected page.
References
- https://wpsec.com/vuln/WPSEC-2026-2055/
- https://plugins.svn.wordpress.org/wpdiscuz/tags/7.6.74/
- https://wordpress.org/plugins/wpdiscuz/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS