Vulnerabilities / Premium Packages / WPSEC-2026-2058

Premium Packages <= 7.3.1 - Authenticated (Subscriber+) Insecure Direct Object Reference via Pay Now and Renew

Medium 5.4 CWE-639Fixed in 7.3.2
ID
WPSEC-2026-2058
Plugin
Premium Packages – Sell Digital Products Securely (wpdm-premium-packages)
Affected
all versions before 7.3.2
Remediation
Update to 7.3.2 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
Weakness
CWE-639
Usage
Plugin Low · Affected versions Low among sites WPSec scans, 2026-10-30
Attack surface
Premium Packages on WPSec AttackSurface
Fix released
Published

Description

The Premium Packages – Sell Digital Products Securely plugin for WordPress is vulnerable to Insecure Direct Object Reference via the Pay Now and Renew feature (the 'wpdmpp_payment_intent' AJAX action) in all versions up to, and including, 7.3.1. This is due to missing ownership validation on the user-supplied 'order_id' parameter, and the handler also had no nonce check. This makes it possible for authenticated attackers, with Subscriber-level access and above, to start payment on other buyers' orders and change their payment method and payment status, for example setting a completed order back to Pending. Because the payment gateways then stored the processed order ID as the session's guest order, the attacker can also view other buyers' guest orders.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0