Widgets for SourceForge Reviews <= 14.2 - Authenticated (Editor+) Stored Cross-Site Scripting via Page Details and Reviews
- ID
- WPSEC-2026-2075
- Plugin
- Widgets for SourceForge Reviews (widgets-for-sourceforge-reviews)
- Affected
- all versions before 14.3
- Remediation
- Update to 14.3 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:L/I:L/A:N
- Weakness
- CWE-79
- Usage
- Plugin Low · Affected versions None seen among sites WPSec scans, 2026-10-30
- Attack surface
- Widgets for SourceForge Reviews on WPSec AttackSurface
- Fix released
- Published
Description
The Widgets for SourceForge Reviews plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the page details and reviews saved through the widget configurator's save-page command in all versions up to, and including, 14.2, due to insufficient input sanitization of the submitted review data and insufficient output escaping of values such as reviewer names and photo URLs in the generated widget HTML. This makes it possible for authenticated attackers, with editor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses a page displaying the review widget. This only affects multi-site installations and installations where unfiltered_html has been disabled.
References
- https://wpsec.com/vuln/WPSEC-2026-2075/
- https://plugins.svn.wordpress.org/widgets-for-sourceforge-reviews/tags/14.3/
- https://wordpress.org/plugins/widgets-for-sourceforge-reviews/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS