Vulnerabilities / Content Egg / WPSEC-2026-2119

Content Egg <= 12.0.0 - Unauthenticated Sensitive Information Exposure via 'post_id' Parameter

Medium 5.3 CWE-200Fixed in 12.1.0
ID
WPSEC-2026-2119
Plugin
Content Egg – Affiliate Product Importer & Price Comparison (content-egg)
Affected
all versions before 12.1.0
Remediation
Update to 12.1.0 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Weakness
CWE-200
Usage
Plugin Low · Affected versions Low among sites WPSec scans, 2026-10-30
Attack surface
Content Egg on WPSec AttackSurface
Fix released
Published

Description

The Content Egg plugin for WordPress is vulnerable to Sensitive Information Exposure via the 'post_id' parameter of the render-blocks REST endpoint, the product data REST endpoint, and its shortcodes and blocks in all versions up to, and including, 12.0.0, due to the plugin rendering or returning the products attached to the requested post without checking that the post is public. The render-blocks endpoint accepts requests from anyone, and the product data endpoint served password-protected posts. This makes it possible for unauthenticated attackers to read the product data stored on draft, private or password-protected posts.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0