Vulnerabilities / WP Shopify / WPSEC-2026-2120
WP Shopify <= 1.6.0 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode Attributes
Medium 6.4
CWE-79Fixed in 1.7.0
- ID
- WPSEC-2026-2120
- Plugin
- External Store for Shopify (wp-shopify)
- Affected
- all versions before 1.7.0
- Remediation
- Update to 1.7.0 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
- Weakness
- CWE-79
- Usage
- Plugin Low · Affected versions None seen among sites WPSec scans, 2026-10-30
- Attack surface
- WP Shopify on WPSec AttackSurface
- Fix released
- Published
Description
The External Store for Shopify plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'product-page' and 'thumb-size' attributes of the [wp-shopify] shortcode in all versions up to, and including, 1.6.0 due to insufficient input sanitization and output escaping. The attribute values were placed directly into href and img src attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
References
- https://wpsec.com/vuln/WPSEC-2026-2120/
- https://plugins.svn.wordpress.org/wp-shopify/tags/1.7.0/
- https://wordpress.org/plugins/wp-shopify/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS