Vulnerabilities / Pie Register / WPSEC-2026-2121

Pie Register <= 3.8.4.15 - Unauthenticated Missing Authorization to Plugin Settings Reset

Medium 5.3 CWE-862Fixed in 3.8.4.16
ID
WPSEC-2026-2121
Plugin
Pie Register – User Registration, Profiles & Content Restriction (pie-register)
Affected
all versions before 3.8.4.16
Remediation
Update to 3.8.4.16 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
Weakness
CWE-862
Usage
Plugin Low · Affected versions Low among sites WPSec scans, 2026-10-30
Attack surface
Pie Register on WPSec AttackSurface
Fix released
Published

Description

The pie-register plugin for WordPress is vulnerable to unauthorized modification of data in all versions up to, and including, 3.8.4.15 due to a missing capability and nonce check on the settings reset routine, which ran whenever the 'piereg_default_settings' POST parameter was present. This makes it possible for unauthenticated attackers to reset all of the plugin's settings to their defaults, wiping the site's registration configuration.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0