Vulnerabilities / Pie Register / WPSEC-2026-2122
Pie Register <= 3.8.4.15 - Authenticated (Contributor+) Missing Authorization to Invitation Code Update
Medium 4.3
CWE-862Fixed in 3.8.4.16
- ID
- WPSEC-2026-2122
- Plugin
- Pie Register – User Registration, Profiles & Content Restriction (pie-register)
- Affected
- all versions before 3.8.4.16
- Remediation
- Update to 3.8.4.16 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
- Weakness
- CWE-862
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-10-30
- Attack surface
- Pie Register on WPSec AttackSurface
- Fix released
- Published
Description
The pie-register plugin for WordPress is vulnerable to unauthorized modification of data via the pireg_update_invitation_code AJAX action in all versions up to, and including, 3.8.4.15. This is due to a missing capability check in the pireg_update_invitation_code_cb_url() function, which only verified the 'pieregister_front_admin' nonce, and that nonce was also printed on the post editing screens. This makes it possible for authenticated attackers, with Contributor-level access and above, to modify the name, description and usage limit of arbitrary invitation codes.
References
- https://wpsec.com/vuln/WPSEC-2026-2122/
- https://plugins.svn.wordpress.org/pie-register/tags/3.8.4.16/
- https://wordpress.org/plugins/pie-register/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS