Vulnerabilities / Hide My WP Ghost / WPSEC-2026-2131

Hide My WP Ghost <= 7.0.15 - Unauthenticated Stored Cross-Site Scripting via Link Rewriting

Medium 5.4 CWE-79Fixed in 7.0.16
ID
WPSEC-2026-2131
Plugin
Hide My WP Ghost – Security & Firewall (hide-my-wp)
Affected
all versions before 7.0.16
Remediation
Update to 7.0.16 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:N
Weakness
CWE-79
Usage
Plugin Low · Affected versions None seen among sites WPSec scans, 2026-10-30
Attack surface
Hide My WP Ghost on WPSec AttackSurface
Fix released
Published

Description

The Hide My WP Ghost plugin for WordPress is vulnerable to Stored Cross-Site Scripting via its output link-rewriting feature in all versions up to, and including, 7.0.15. When the 'hmwp_fix_relative' option is enabled, the link-rewriting regex callback (replaceLinks/_rel2abs in models/Rewrite.php) could capture a value that ran past an HTML tag boundary, and escaped '..\/' relative paths were not recognized, so attacker-influenced page content containing angle brackets was rewritten back into the page HTML. This makes it possible for unauthenticated attackers who can place content on the site, such as comments, to break the page markup and inject arbitrary web scripts that execute whenever a user accesses an affected page, provided the plugin's relative-link rewriting is active.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0