Event Tickets and Registration <= 5.30.2 - Authenticated (Contributor+) Insecure Direct Object Reference to Ticket Modification and Duplication
- ID
- WPSEC-2026-2139
- Plugin
- Event Tickets and Registration (event-tickets)
- Affected
- all versions before 5.30.3
- Remediation
- Update to 5.30.3 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
- Weakness
- CWE-639
- Usage
- Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-10-30
- Attack surface
- Event Tickets and Registration on WPSec AttackSurface
- Fix released
- Published
Description
The Event Tickets and Registration plugin for WordPress is vulnerable to Insecure Direct Object Reference in the ticket editor (the ticket add/update, edit and duplicate AJAX actions, ticket ordering, and the single ticket REST endpoint) in all versions up to, and including, 5.30.2. This is due to the plugin checking permissions on the post named in the request without checking that the supplied ticket ID belongs to that post. This makes it possible for authenticated attackers with Contributor-level access and above to change, read or duplicate tickets that belong to other users' events, for example changing their prices or settings, by naming a post they can edit.
References
- https://wpsec.com/vuln/WPSEC-2026-2139/
- https://plugins.svn.wordpress.org/event-tickets/tags/5.30.3/
- https://wordpress.org/plugins/event-tickets/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS