Vulnerabilities / Event Tickets and Registration / WPSEC-2026-2142
Event Tickets and Registration <= 5.30.2 - Authenticated (Contributor+) Missing Authorization to Attendee Check-In
Medium 4.3
CWE-862Fixed in 5.30.3
- ID
- WPSEC-2026-2142
- Plugin
- Event Tickets and Registration (event-tickets)
- Affected
- all versions before 5.30.3
- Remediation
- Update to 5.30.3 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
- Weakness
- CWE-862
- Usage
- Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-10-30
- Attack surface
- Event Tickets and Registration on WPSec AttackSurface
- Fix released
- Published
Description
The Event Tickets and Registration plugin for WordPress is vulnerable to unauthorized modification of data via the attendee check-in and undo check-in AJAX actions and the QR code check-in in all versions up to, and including, 5.30.2. This is due to these actions only checking the generic 'edit_posts' capability, without checking that the user can manage the attendees of the attendee's own event. This makes it possible for authenticated attackers with Contributor-level access and above to check in attendees of events they do not manage, or undo their check-in.
References
- https://wpsec.com/vuln/WPSEC-2026-2142/
- https://plugins.svn.wordpress.org/event-tickets/tags/5.30.3/
- https://wordpress.org/plugins/event-tickets/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS