Vulnerabilities / Essential Real Estate / WPSEC-2026-2163
Essential Real Estate <= 5.3.4 - Authenticated (Customer+) Insecure Direct Object Reference to Arbitrary Property Modification via Front-End Property Form
Medium 4.3
CWE-639Fixed in 5.3.5
- ID
- WPSEC-2026-2163
- Plugin
- Essential Real Estate (essential-real-estate)
- Affected
- all versions before 5.3.5
- Remediation
- Update to 5.3.5 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
- Weakness
- CWE-639
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-10-31
- Attack surface
- Essential Real Estate on WPSec AttackSurface
- Fix released
- Published
Description
The Essential Real Estate plugin for WordPress is vulnerable to Insecure Direct Object Reference via the front-end property edit form in all versions up to, and including, 5.3.4, due to missing ownership validation on the user-supplied 'property_id' parameter in the 'edit-property' branch of the property submission handler. This makes it possible for authenticated attackers, with ERE Customer-level access and above (the role the plugin gives to users who register through its front-end form), to overwrite the content, details and metadata of properties belonging to other users.
References
- https://wpsec.com/vuln/WPSEC-2026-2163/
- https://plugins.svn.wordpress.org/essential-real-estate/tags/5.3.5/
- https://wordpress.org/plugins/essential-real-estate/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS