Vulnerabilities / PayHere Payment Gateway / WPSEC-2026-2169
PayHere Payment Gateway <= 2.4.5 - Missing Authorization to Payment Capture
Medium 4.3
CWE-862Fixed in 2.4.6
- ID
- WPSEC-2026-2169
- Plugin
- PayHere Payment Gateway (payhere-payment-gateway)
- Affected
- all versions before 2.4.6
- Remediation
- Update to 2.4.6 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
- Weakness
- CWE-862
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-10-31
- Attack surface
- PayHere Payment Gateway on WPSec AttackSurface
- Fix released
- Published
Description
The PayHere Payment Gateway plugin for WordPress is vulnerable to unauthorized modification of data via the payhere_capture AJAX action (capture_payment() function) in all versions up to, and including, 2.4.5, due to a missing capability check and missing nonce validation. This makes it possible for authenticated attackers, with Subscriber-level access and above, to capture authorized (held) PayHere payments for arbitrary orders, an action meant only for store managers.
References
- https://wpsec.com/vuln/WPSEC-2026-2169/
- https://plugins.svn.wordpress.org/payhere-payment-gateway/tags/2.4.6/
- https://wordpress.org/plugins/payhere-payment-gateway/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS