Vulnerabilities / Chameleon / WPSEC-2026-2173

Chameleon <= 1.4.9 - Missing Authorization to Unauthenticated Style Settings Update

Medium 5.3 CWE-862Fixed in 1.5.0
ID
WPSEC-2026-2173
Plugin
Chameleon (chameleon)
Affected
all versions before 1.5.0
Remediation
Update to 1.5.0 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
Weakness
CWE-862
Usage
Plugin Low · Affected versions None seen among sites WPSec scans, 2026-10-31
Attack surface
Chameleon on WPSec AttackSurface
Fix released
Published

Description

The Chameleon plugin for WordPress is vulnerable to unauthorized modification of data via the third-party style switcher in all versions up to, and including, 1.4.9, due to a missing capability check on the wpc_third_party_support() function. The function is hooked to admin_init, which also fires for unauthenticated requests to admin-ajax.php and admin-post.php. This makes it possible for unauthenticated attackers to overwrite the site-wide Alphabetic Pagination style and template choices stored in the wp_chameleon option with arbitrary values through the 'ap_style' and 'ap_template' parameters. The Alphabetic Pagination plugin must be active.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0