Vulnerabilities / YML for Yandex Market / WPSEC-2026-2178
YML for Yandex Market <= 5.10.0 - Unauthenticated Sensitive Information Exposure via Log File
Medium 5.9
CWE-532Fixed in 5.11.0
- ID
- WPSEC-2026-2178
- Plugin
- YML for Yandex Market (yml-for-yandex-market)
- Affected
- from 5.8.0 before 5.11.0
- Remediation
- Update to 5.11.0 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
- Weakness
- CWE-532
- Usage
- Plugin Low · Affected versions None seen among sites WPSec scans, 2026-10-31
- Attack surface
- YML for Yandex Market on WPSec AttackSurface
- Fix released
- Published
Description
The YML for Yandex Market plugin for WordPress is vulnerable to Sensitive Information Exposure via its log file in versions 5.8.0 up to, and including, 5.10.0, due to the response_to_yandex() function writing the request headers, including the Yandex Market 'Api-Key', to the publicly accessible wp-content/uploads/y4ym/yml-for-yandex-market.log file. This makes it possible for unauthenticated attackers to get the site's Yandex Market API key when plugin logging is enabled.
References
- https://wpsec.com/vuln/WPSEC-2026-2178/
- https://plugins.svn.wordpress.org/yml-for-yandex-market/tags/5.11.0/
- https://wordpress.org/plugins/yml-for-yandex-market/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS