Vulnerabilities / Relevanssi / WPSEC-2026-2179

Relevanssi <= 4.28.6 - Authenticated (Contributor+) Sensitive Information Exposure via Admin Search

Medium 4.3 CWE-862Fixed in 4.28.7
ID
WPSEC-2026-2179
Plugin
Relevanssi – A Better Search (relevanssi)
Affected
all versions before 4.28.7
Remediation
Update to 4.28.7 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Weakness
CWE-862
Usage
Plugin Low · Affected versions Low among sites WPSec scans, 2026-10-31
Attack surface
Relevanssi on WPSec AttackSurface
Fix released
Published

Description

The Relevanssi plugin for WordPress is vulnerable to Sensitive Information Exposure via the admin search in all versions up to, and including, 4.28.6. Draft, pending and scheduled posts were included in admin search results without checking whether the current user can read each post. This makes it possible for authenticated attackers, with Contributor-level access and above, to view draft, pending and future posts written by other users.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0