Vulnerabilities / GutenKit / WPSEC-2026-2217

GutenKit <= 2.5.4 - Authenticated (Author+) Stored Cross-Site Scripting via Custom CSS

Medium 6.4 CWE-79Fixed in 2.5.5
ID
WPSEC-2026-2217
Plugin
GutenKit – Page Builder Blocks, Patterns, and Templates for Gutenberg Block Editor (gutenkit-blocks-addon)
Affected
all versions before 2.5.5
Remediation
Update to 2.5.5 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Weakness
CWE-79
Usage
Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-11-03
Attack surface
GutenKit on WPSec AttackSurface
Fix released
Published

Description

The GutenKit plugin for WordPress is vulnerable to Stored Cross-Site Scripting via stored custom CSS (the 'postBodyCss' page settings meta and GutenKit block CSS attributes) in all versions up to, and including, 2.5.4, due to an insufficient CSS sanitizer that removes dangerous keywords in a single pass, so nested keywords collapse into a closing '</style>' tag when they are removed. This makes it possible for authenticated attackers, with author-level access and above, to break out of the inline style block and inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0