Vulnerabilities / wpForo Forum / WPSEC-2026-2221

wpForo Forum <= 3.2.2 - Authenticated (Subscriber+) Missing Authorization to Guest Post Modification

Medium 4.3 CWE-862Fixed in 3.2.3
ID
WPSEC-2026-2221
Plugin
wpForo Forum (wpforo)
Affected
all versions before 3.2.3
Remediation
Update to 3.2.3 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
Weakness
CWE-862
Usage
Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-11-03
Attack surface
wpForo Forum on WPSec AttackSurface
Fix released
Published

Description

The wpForo Forum plugin for WordPress is vulnerable to unauthorized modification of data via the post_edit action in all versions up to, and including, 3.2.2. This is because the Posts::edit() method treated any edit of a guest-authored post (userid 0) as guest posting whenever the request contained name and email fields, and then skipped the edit permission check, including for logged-in users. This makes it possible for authenticated attackers with subscriber-level access and above to modify the content of any guest-authored forum post.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0