Vulnerabilities / wpForo Forum / WPSEC-2026-2223

wpForo Forum <= 3.2.2 - Authenticated (Subscriber+) Stored Cross-Site Scripting via Post Content in Topic Moderation Tools

Medium 6.4 CWE-79Fixed in 3.2.3
ID
WPSEC-2026-2223
Plugin
wpForo Forum (wpforo)
Affected
all versions before 3.2.3
Remediation
Update to 3.2.3 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Weakness
CWE-79
Usage
Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-11-03
Attack surface
wpForo Forum on WPSec AttackSurface
Fix released
Published

Description

The wpForo Forum plugin for WordPress is vulnerable to Stored Cross-Site Scripting via post content and titles shown in the topic split and reply move moderation tools in all versions up to, and including, 3.2.2, due to insufficient output escaping. Post excerpts had their tags stripped but were echoed into a label title attribute and the label text without escaping, so quote characters could inject attributes. This makes it possible for authenticated attackers with subscriber-level access and above to inject arbitrary web scripts that execute when a moderator opens these moderation tools for the topic.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0