Vulnerabilities / Recipe Maker / WPSEC-2026-2228

Recipe Maker <= 10.9.1 - Authenticated (Contributor+) Insecure Direct Object Reference to Arbitrary Post and List Unpublishing and Author Reassignment

Medium 5.4 CWE-639Fixed in 10.9.2
ID
WPSEC-2026-2228
Plugin
WP Recipe Maker (wp-recipe-maker)
Affected
from 9.0.0 before 10.9.2
Remediation
Update to 10.9.2 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L
Weakness
CWE-639
Usage
Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-11-03
Attack surface
Recipe Maker on WPSec AttackSurface
Fix released
Published

Description

The WP Recipe Maker plugin for WordPress is vulnerable to Insecure Direct Object Reference in versions 9.0.0 through 10.9.1. When a post is saved, the plugin updates every list it finds in that post's content (wprm-list shortcode or wp-recipe-maker/list block) without checking that the saving user can edit those lists. For the block it also does not check that the referenced ID is a list at all. This makes it possible for authenticated attackers, with contributor-level access and above, to change the post status, dates, author and parent post relation of lists and other posts they do not own. This includes unpublishing other users' published posts and lists and reassigning them to the attacker.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0