Vulnerabilities / Recipe Maker / WPSEC-2026-2229

Recipe Maker <= 10.9.1 - Authenticated (Contributor+) Stored Cross-Site Scripting via Custom Fields

Medium 6.4 CWE-79Fixed in 10.9.2
ID
WPSEC-2026-2229
Plugin
WP Recipe Maker (wp-recipe-maker)
Affected
all versions before 10.9.2
Remediation
Update to 10.9.2 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Weakness
CWE-79
Usage
Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-11-03
Attack surface
Recipe Maker on WPSec AttackSurface
Fix released
Published

Description

The WP Recipe Maker plugin for WordPress is vulnerable to Stored Cross-Site Scripting via WordPress's generic Custom Fields feature in all versions up to, and including, 10.9.1. The plugin's wprm_ and wprmp_ post meta keys are not marked as protected, so raw values can be written to recipe and list fields without going through the plugin's sanitization. Some of these fields, such as recipe notes, are output without escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts into recipes and lists they can edit that will execute whenever a user accesses a page displaying them.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0