Vulnerabilities / Recipe Maker / WPSEC-2026-2230

Recipe Maker <= 10.9.1 - Authenticated (Contributor+) Stored Cross-Site Scripting via List Roundup Items

Medium 6.4 CWE-79Fixed in 10.9.2
ID
WPSEC-2026-2230
Plugin
WP Recipe Maker (wp-recipe-maker)
Affected
from 9.0.0 before 10.9.2
Remediation
Update to 10.9.2 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Weakness
CWE-79
Usage
Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-11-03
Attack surface
Recipe Maker on WPSec AttackSurface
Fix released
Published

Description

The WP Recipe Maker plugin for WordPress is vulnerable to Stored Cross-Site Scripting via list roundup items in versions 9.0.0 through 10.9.1. The list saver keeps arbitrary, unsanitized item data keys, and the list shortcode joins those keys and values into a wprm-recipe-roundup-item shortcode string without validating them. This makes it possible for authenticated attackers, with contributor-level access and above, to break out of the generated shortcode and inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0