Vulnerabilities / Recipe Maker / WPSEC-2026-2231

Recipe Maker <= 10.9.1 - Unauthenticated Sensitive Information Exposure via Password-Protected Recipe Content

Medium 5.3 CWE-200Fixed in 10.9.2
ID
WPSEC-2026-2231
Plugin
WP Recipe Maker (wp-recipe-maker)
Affected
all versions before 10.9.2
Remediation
Update to 10.9.2 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Weakness
CWE-200
Usage
Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-11-03
Attack surface
Recipe Maker on WPSec AttackSurface
Fix released
Published

Description

The WP Recipe Maker plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 10.9.1 due to missing password checks on the recipe REST API field, the frontend-format recipe data endpoint, and the recipe JSON-LD metadata (including the Yoast and Rank Math integrations). This makes it possible for unauthenticated attackers to read recipe content that is protected by a recipe or parent post password, including the recipe's post_password value through the REST API.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0