Vulnerabilities / WP Compress / WPSEC-2026-2236

WP Compress <= 7.30.00 - Unauthenticated Sensitive Information Exposure via Cache Purge Log File

Medium 5.9 CWE-532Fixed in 7.30.30
ID
WPSEC-2026-2236
Plugin
WP Compress – Instant Performance & Speed Optimization (wp-compress-image-optimizer)
Affected
all versions before 7.30.30
Remediation
Update to 7.30.30 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-532
Usage
Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-11-03
Attack surface
WP Compress on WPSec AttackSurface
Fix released
Published

Description

The WP Compress plugin for WordPress is vulnerable to Sensitive Information Exposure via the cache purge log in all versions up to, and including, 7.30.00, due to the plugin writing the complete old and new plugin options, including the WP Compress API key, unmasked to a predictable, publicly accessible file at wp-content/cachePurging.txt whenever a cache purge happens while the plugin's debug log is enabled. This makes it possible for unauthenticated attackers to download the file and obtain the site's WP Compress API key and other plugin configuration, on sites where an administrator has enabled the debug log.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0