MasterStudy LMS WordPress Plugin – for Online Courses and Education <= 3.7.56 - Authenticated (Subscriber+) Arbitrary Shortcode Execution via Course Reviews
- ID
- WPSEC-2026-2243
- Plugin
- MasterStudy LMS WordPress Plugin – for Online Courses and Education (masterstudy-lms-learning-management-system)
- Affected
- all versions before 3.7.57
- Remediation
- Update to 3.7.57 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
- Weakness
- CWE-94
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-11-03
- Attack surface
- MasterStudy LMS WordPress Plugin – for Online Courses and Education on WPSec AttackSurface
- Fix released
- Published
Description
The MasterStudy LMS WordPress Plugin – for Online Courses and Education plugin for WordPress is vulnerable to arbitrary shortcode execution via course reviews in all versions up to, and including, 3.7.56, due to the stm_lms_add_review AJAX action storing review text without removing shortcodes and the review listing rendering that text through the 'the_content' filter, which runs do_shortcode. This makes it possible for authenticated attackers, with Subscriber-level access and above, to execute arbitrary registered shortcodes. The attacker sees the output at once, because a review still awaiting moderation is shown to its author. When reviews are limited to enrolled students, the attacker must also have access to the course.
References
- https://wpsec.com/vuln/WPSEC-2026-2243/
- https://plugins.svn.wordpress.org/masterstudy-lms-learning-management-system/tags/3.7.57/
- https://wordpress.org/plugins/masterstudy-lms-learning-management-system/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS