Vulnerabilities / Better Search / WPSEC-2026-2245
Better Search <= 4.5.2 - Unauthenticated Sensitive Information Exposure via 'post_type' Parameter
Medium 5.3
CWE-200Fixed in 4.5.3
- ID
- WPSEC-2026-2245
- Plugin
- Better Search – Relevant search results for WordPress (better-search)
- Affected
- all versions before 4.5.3
- Remediation
- Update to 4.5.3 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- Weakness
- CWE-200
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-11-03
- Attack surface
- Better Search on WPSec AttackSurface
- Fix released
- Published
Description
The Better Search plugin for WordPress is vulnerable to Sensitive Information Exposure via the 'post_type' search parameter in all versions up to, and including, 4.5.2 due to the parameter being passed into the search query without restricting it to searchable post types, combined with a default post status that included 'inherit'. This makes it possible for unauthenticated attackers to search for and view revision content of draft, private and password-protected posts, as well as internal content such as menu items, through front-end search results.
References
- https://wpsec.com/vuln/WPSEC-2026-2245/
- https://plugins.svn.wordpress.org/better-search/tags/4.5.3/
- https://wordpress.org/plugins/better-search/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS