Events Calendar for FooEvents <= 2.0.5 - Authenticated (Subscriber+) Missing Authorization to Eventbrite Event Import
- ID
- WPSEC-2026-2248
- Plugin
- Events Calendar by FooEvents (fooevents-calendar)
- Affected
- all versions before 2.0.6
- Remediation
- Update to 2.0.6 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
- Weakness
- CWE-862
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-11-03
- Attack surface
- Events Calendar for FooEvents on WPSec AttackSurface
- Fix released
- Published
Description
The Events Calendar by FooEvents plugin for WordPress is vulnerable to unauthorized modification of data via the fooevents-eventbrite-import AJAX action in all versions up to, and including, 2.0.5, due to a missing capability check and missing nonce verification in the import_events_from_eventbrite function. This makes it possible for authenticated attackers, with Subscriber-level access and above, to trigger an import from the site's connected Eventbrite account using the stored Eventbrite token. The import creates published event posts, and overwrites and re-publishes existing imported event posts.
References
- https://wpsec.com/vuln/WPSEC-2026-2248/
- https://plugins.svn.wordpress.org/fooevents-calendar/tags/2.0.6/
- https://wordpress.org/plugins/fooevents-calendar/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS