Vulnerabilities / Gutenberg WooCommerce Builder Blocks for ShopEngine, Variation Swatches, Wishlist, Products Compare / WPSEC-2026-2258
Gutenberg WooCommerce Builder Blocks for ShopEngine, Variation Swatches, Wishlist, Products Compare <= 2.4.3 - Authenticated (Contributor+) Missing Authorization to Arbitrary Post CSS and Font Link Meta Update
Medium 4.3
CWE-862Fixed in 2.4.4
- ID
- WPSEC-2026-2258
- Plugin
- ShopEngine Gutenberg WooCommerce Builder Blocks Addon – All in One WooCommerce Solution (blocks-for-shopengine)
- Affected
- all versions before 2.4.4
- Remediation
- Update to 2.4.4 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
- Weakness
- CWE-862
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-11-03
- Attack surface
- Gutenberg WooCommerce Builder Blocks for ShopEngine, Variation Swatches, Wishlist, Products Compare on WPSec AttackSurface
- Fix released
- Published
Description
The ShopEngine Gutenberg WooCommerce Builder Blocks Addon plugin for WordPress is vulnerable to unauthorized modification of data in all versions up to, and including, 2.4.3 due to a missing capability check on the store_css AJAX function (gutenova_store_css action), which only verified a nonce exposed in the block editor. This makes it possible for authenticated attackers, with Contributor-level access and above, to overwrite the gutenova_css and gutenova_font_link meta of arbitrary posts they are not permitted to edit, altering the styling of those posts.
References
- https://wpsec.com/vuln/WPSEC-2026-2258/
- https://plugins.svn.wordpress.org/blocks-for-shopengine/tags/2.4.4/
- https://wordpress.org/plugins/blocks-for-shopengine/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS