Vulnerabilities / پارسی دیت – Parsi Date / WPSEC-2026-2267
پارسی دیت – Parsi Date <= 6.4 - Authenticated (Contributor+) Stored Cross-Site Scripting via Calendar Block 'theme' Attribute
Medium 6.4
CWE-79Fixed in 6.5
- ID
- WPSEC-2026-2267
- Plugin
- پارسی دیت – Parsi Date (wp-parsidate)
- Affected
- from 6.3 before 6.5
- Remediation
- Update to 6.5 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
- Weakness
- CWE-79
- Usage
- Plugin Low · Affected versions None seen among sites WPSec scans, 2026-11-03
- Attack surface
- پارسی دیت – Parsi Date on WPSec AttackSurface
- Fix released
- Published
Description
The Parsi Date plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Calendar block's 'theme' attribute in all versions up to, and including, 6.4 due to insufficient input sanitization and output escaping. The theme value is placed directly into the class attribute of the calendar table. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses a page containing the calendar block.
References
- https://wpsec.com/vuln/WPSEC-2026-2267/
- https://plugins.svn.wordpress.org/wp-parsidate/tags/6.5/
- https://wordpress.org/plugins/wp-parsidate/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS