Vulnerabilities / Cooked / WPSEC-2026-2269

Cooked <= 1.16.2 - Authenticated (Contributor+) Stored Cross-Site Scripting via Recipe Fields

Medium 6.4 CWE-79Fixed in 1.17.0
ID
WPSEC-2026-2269
Plugin
Cooked – Recipe Management (cooked)
Affected
all versions before 1.17.0
Remediation
Update to 1.17.0 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Weakness
CWE-79
Usage
Plugin Low · Affected versions Low among sites WPSec scans, 2026-11-03
Attack surface
Cooked on WPSec AttackSurface
Fix released
Published

Description

The Cooked plugin for WordPress is vulnerable to Stored Cross-Site Scripting via recipe fields such as the excerpt, notes, and directions in all versions up to, and including, 1.16.2. This is due to the [cooked-info] shortcode registering a wp_kses_allowed_html filter that permits <script> tags and never removing it, so later wp_kses_post calls on the same request allow scripts. Recipe input was also entity-decoded only once before sanitization and decoded again at output, which let double-encoded markup survive. This makes it possible for authenticated attackers with contributor-level access and above to inject arbitrary web scripts in pages that execute whenever a user accesses an injected page.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0