Vulnerabilities / WP Docs / WPSEC-2026-2280

WP Docs <= 2.3.4 - Authenticated (Subscriber+) Missing Authorization to Memphis Documents Import and Rollback

Medium 5.4 CWE-862Fixed in 2.3.5
ID
WPSEC-2026-2280
Plugin
WP Docs (wp-docs)
Affected
all versions before 2.3.5
Remediation
Update to 2.3.5 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L
Weakness
CWE-862
Usage
Plugin Low · Affected versions None seen among sites WPSec scans, 2026-11-03
Attack surface
WP Docs on WPSec AttackSurface
Fix released
Published

Description

The WP Docs plugin for WordPress is vulnerable to unauthorized modification of data in all versions up to, and including, 2.3.4 due to a missing capability check on the wp_docs_import_memphis_docs and wp_docs_import_memphis_rollback AJAX functions. The only protection is a nonce that is also printed to every visitor of a front-end page containing the [wpdocs] shortcode. This makes it possible for authenticated attackers, with Subscriber-level access and above, to import Memphis Documents Library content into WP Docs or roll back a previous import, which deletes the imported folders and resets the related import options.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0