Vulnerabilities / Download Manager / WPSEC-2026-2296

Download Manager <= 3.3.74 - Unauthenticated Sensitive Information Exposure via REST Package Search

Low 3.7 CWE-200Fixed in 3.3.75
ID
WPSEC-2026-2296
Plugin
Download Manager (download-manager)
Affected
from 3.2.04 before 3.3.75
Remediation
Update to 3.3.75 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N
Weakness
CWE-200
Usage
Plugin High · Affected versions High among sites WPSec scans, 2026-11-03
Attack surface
Download Manager on WPSec AttackSurface
Fix released
Published

Description

The Download Manager plugin for WordPress is vulnerable to Sensitive Information Exposure via the wpdm/search REST endpoint in versions 3.2.04 up to, and including, 3.3.74, due to the search endpoint returning every matching package with its raw description and no access check. This makes it possible for unauthenticated attackers to retrieve the titles and descriptions of packages hidden from them by the 'Hide all package info from users without access' setting, and for authenticated attackers, with Subscriber-level access and above, to read the descriptions of password-protected packages.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0