Vulnerabilities / SVG Support / WPSEC-2026-2302

SVG Support <= 2.6.1 - Authenticated (Author+) Stored Cross-Site Scripting via XML-RPC SVG Uploads

Medium 6.4 CWE-79Fixed in 2.6.2
ID
WPSEC-2026-2302
Plugin
SVG Support (svg-support)
Affected
all versions before 2.6.2
Remediation
Update to 2.6.2 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Weakness
CWE-79
Usage
Plugin High · Affected versions High among sites WPSec scans, 2026-11-03
Attack surface
SVG Support on WPSec AttackSurface
Fix released
Published

Description

The SVG Support plugin for WordPress is vulnerable to Stored Cross-Site Scripting via SVG files uploaded over XML-RPC (wp.uploadFile and metaWeblog.newMediaObject, including .svgz) in all versions up to, and including, 2.6.1. This is due to insufficient input sanitization: files stored through wp_upload_bits() bypass the upload prefilters, so they were never run through the SVG sanitizer. This makes it possible for authenticated attackers with Author-level access and above who are permitted to upload SVGs to inject arbitrary web scripts in uploaded SVG files that will execute whenever a user accesses the file.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0