Vulnerabilities / SVG Support / WPSEC-2026-2303

SVG Support <= 2.6.1 - Authenticated (Author+) Stored Cross-Site Scripting via SVG Animation Elements

Medium 4.4 CWE-79Fixed in 2.6.2
ID
WPSEC-2026-2303
Plugin
SVG Support (svg-support)
Affected
all versions before 2.6.2
Remediation
Update to 2.6.2 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Usage
Plugin High · Affected versions High among sites WPSec scans, 2026-11-03
Attack surface
SVG Support on WPSec AttackSurface
Fix released
Published

Description

The SVG Support plugin for WordPress is vulnerable to Stored Cross-Site Scripting via SVG animation elements in all versions up to, and including, 2.6.1. This is due to the SVG sanitizer allowing an animateTransform element whose attributeName targets a link's href and whose values attribute carries a javascript: URL, which lets the animation rewrite the link into a script URL after sanitization in WebKit browsers such as Safari. This makes it possible for authenticated attackers with Author-level access and above who are permitted to upload SVGs to inject arbitrary web scripts that execute when a user views the file and clicks the link.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0