Vulnerabilities / hCaptcha for WP / WPSEC-2026-2311

hCaptcha for WP <= 5.4.1 - Unauthenticated Password Protection Brute Force via REST API 'password' Parameter

Medium 5.3 CWE-307Fixed in 5.5.0
ID
WPSEC-2026-2311
Plugin
hCaptcha for WP (hcaptcha-for-forms-and-more)
Affected
all versions before 5.5.0
Remediation
Update to 5.5.0 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Weakness
CWE-307
Usage
Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-11-03
Attack surface
hCaptcha for WP on WPSec AttackSurface
Fix released
Published

Description

The hCaptcha for WP plugin for WordPress is vulnerable to a protection mechanism bypass in its password-protected post and page integration in all versions up to, and including, 5.4.1. This is due to the hCaptcha challenge being enforced only on the post password form (wp-login.php?action=postpass), while the WordPress REST API posts and comments endpoints accept a 'password' parameter and check it without any CAPTCHA. This makes it possible for unauthenticated attackers to brute-force the passwords of password-protected posts and pages without solving the hCaptcha challenge, and to read their content once a password is guessed.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0