Easy Social Icons <= 4.0.2 - Authenticated (Author+) Stored Cross-Site Scripting via SVG File Upload
- ID
- WPSEC-2026-2326
- Plugin
- Easy Social Icons (easy-social-icons)
- Affected
- from 3.2.8 before 4.0.3
- Remediation
- Update to 4.0.3 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
- Weakness
- CWE-79
- Usage
- Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-11-03
- Attack surface
- Easy Social Icons on WPSec AttackSurface
- Fix released
- Published
Description
The Easy Social Icons plugin for WordPress is vulnerable to Stored Cross-Site Scripting via SVG file uploads in versions 3.2.8 up to, and including, 4.0.2. This is due to the plugin adding the SVG MIME type to the allowed upload types for every user who can upload files, without checking for the unfiltered_html capability and without validating the file contents. This makes it possible for authenticated attackers, with Author-level access and above, to upload SVG files containing malicious scripts to the media library. These scripts will execute whenever a user accesses the uploaded file.
References
- https://wpsec.com/vuln/WPSEC-2026-2326/
- https://plugins.svn.wordpress.org/easy-social-icons/tags/4.0.3/
- https://wordpress.org/plugins/easy-social-icons/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS