Vulnerabilities / LatePoint / WPSEC-2026-2337

LatePoint <= 5.7.6 - Unauthenticated Authentication Bypass to Customer Account Takeover via 'password_reset_token' Parameter

Medium 4.8 CWE-640Fixed in 5.7.7
ID
WPSEC-2026-2337
Plugin
Appointment Booking Plugin – LatePoint | Calendar & Scheduling for WordPress (latepoint)
Affected
all versions before 5.7.7
Remediation
Update to 5.7.7 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N
Weakness
CWE-640
Usage
Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-11-03
Attack surface
LatePoint on WPSec AttackSurface
Fix released
Published

Description

The LatePoint plugin for WordPress is vulnerable to Authentication Bypass in all versions up to, and including, 5.7.6, due to insufficient validation of the 'password_reset_token' parameter in the customer cabinet password change handler. A crafted value makes the token lookup return the first customer record instead of the record that owns the token. This makes it possible for unauthenticated attackers who know that customer's email address to request a password reset for the account and set a new password without receiving the reset email, taking over the customer account and, on sites with the 'Use WordPress users as customers' option enabled, a linked subscriber-level WordPress account.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0