Vulnerabilities / WP Compress / WPSEC-2026-2341

WP Compress <= 7.30.35 - Cross-Site Request Forgery via Multiple AJAX Actions and Admin Query Flags

Medium 4.3 CWE-352Fixed in 7.30.45
ID
WPSEC-2026-2341
Plugin
WP Compress – Instant Performance & Speed Optimization (wp-compress-image-optimizer)
Affected
all versions before 7.30.45
Remediation
Update to 7.30.45 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
Weakness
CWE-352
Usage
Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-11-03
Attack surface
WP Compress on WPSec AttackSurface
Fix released
Published

Description

The WP Compress plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 7.30.35. This is due to missing nonce validation on several AJAX actions (including wps_ic_compress_live, wps_ic_restore_live, wps_ic_media_library_bulk_heartbeat and wpc_v2_set_concurrency_manual) and on state-changing admin query flags (such as reset_compress, resetHistory, resetTest, forceInitial, regen and force_update). This makes it possible for unauthenticated attackers to compress or restore media library images, reset compression status and test data, and change plugin processing settings, granted they can trick a site administrator, or a user who can upload files, into performing an action such as clicking on a link.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0