Vulnerabilities / Event Organiser / WPSEC-2026-2345
Event Organiser <= 3.12.11 - Authenticated (Contributor+) Stored Cross-Site Scripting via 'no_events' Shortcode Attribute
Medium 6.4
CWE-79Fixed in 3.12.12
- ID
- WPSEC-2026-2345
- Plugin
- Event Organiser (event-organiser)
- Affected
- all versions before 3.12.12
- Remediation
- Update to 3.12.12 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
- Weakness
- CWE-79
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-11-03
- Attack surface
- Event Organiser on WPSec AttackSurface
- Fix released
- Published
Description
The Event Organiser plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'no_events' attribute of the eo_events shortcode in all versions up to, and including, 3.12.11 due to insufficient input sanitization and output escaping when the shortcode is used with an inline placeholder template. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page displaying an empty event list.
References
- https://wpsec.com/vuln/WPSEC-2026-2345/
- https://plugins.svn.wordpress.org/event-organiser/tags/3.12.12/
- https://wordpress.org/plugins/event-organiser/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS